problème

Cmath pour LuaLaTeX
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

problème

Message par yax44 »

Bonjour,

Je n'ai pas eu le temps jusqu'à maintenant d'approfondir CmathLuaTex.
Aujourd'hui, j'ai donc repris ma clé USb et j'ai tenté de la mettre à jour afin de bénéficier des nouveautés (systèmes linéaires, calcul matriciel, ...).
J'ai donc remplacé les anciens fichiers CmathLuaTex.lua et CmathLuaTes.sty par les nouveaux.
Je ne sais pas trop ce que j'ai fait mais en tout cas, plus rien ne marche : la touche F9 est devenue inopérante (cf capture d'écran en pièce jointe).
J'ai l'impression que j'ai tout cassé... :oops:

Est-ce que je dois recommencer la création de ma clé usb ?

Merci d'avance.

jean-françois
Pièces jointes
Cmath.PNG
Cmath.PNG (7.33 Kio) Consulté 6778 fois
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

Bonjour,
avez-vous mis aussi à jour les scripts texworks : https://github.com/cdevalland/cmathluat ... ks/scripts ?
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,
Je viens de mettre à jour les scripts et cela ne change malheureusement rien.
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

Bizarre, d'autant plus qu'il n'y a pas de caractère '/' à la ligne 1 de ce fichier lua.
Pouvez-vous vérifier que le fichier est correct ?
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,

Effectivement, ce fichier lua n'était pas correct.
Je l'ai effacé et remplacé et ça fonctionne !

Il me reste quelques soucis :

1) Problème avec la touche F9 :
les fonctions TVal, TSig, ... se comportent bizarrement avec F9; après compil, l'affichage de ces fonctions donne 1/(x-3)+1/(2x+1) ???
Par contre, tout fonctionne correctement avec Ctrl+F9.

2) La fonction TVar ne détecte pas les valeurs interdites : j'ai des barres simples et non des doubles barres sous -1 et 1 pour la fonction f définie par f(t)=t^2/(t^2-1) (exemple de la page 13 de la doc))
Idem pour les zones interdites : pour la fonction f définie par f(x)=sqrt(x^2-1) (exemple de la page 14 de la doc), la compil donne comme affichage "Erreur Xcas"

3) Pour les graphiques :
si je tente l'exemple de la page 26 de la doc, j'ai un message d'erreur pour l'option Stealth utilisée dans l'affichage des axes : Package pgf Error : unknown arrow tip kind 'Stealth'

Au sujet des graphiques, est-ce qu'il y a des fonctions automatisant le tracé des courbes ? je n'ai rien vu dans la doc à ce sujet.


Un très grand merci d'avance pour tout !

Jean-François
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

yax44 a écrit : 1) Problème avec la touche F9 :
les fonctions TVal, TSig, ... se comportent bizarrement avec F9; après compil, l'affichage de ces fonctions donne 1/(x-3)+1/(2x+1) ??? Par contre, tout fonctionne correctement avec Ctrl+F9.
Bonjour,
je ne comprends pas. Ce résultat doit provenir d'un précédent appel à XCAS contenu dans le fichier giac.out. Mais cela ne devrait pas fonctionner non plus avec Ctrl+F9... La différence que je vois, c'est que l'interpréteur LUA utilisé par Lualatex lors de la compilation n'est peut-être pas le même que celui utilisé par texworks (avec Ctrl+F9). Vérifiez quand même que vous n'avez pas un vieux fichier cmathluatex.lua qui traine dans le répertoire de votre fichier tex ou dans le répertoire texlive/texmf-local de la clé USB. Il faut aussi mettre à jour cette version pour que ça compile bien.
yax44 a écrit : 2) La fonction TVar ne détecte pas les valeurs interdites : j'ai des barres simples et non des doubles barres sous -1 et 1 pour la fonction f définie par f(t)=t^2/(t^2-1) (exemple de la page 13 de la doc))
Idem pour les zones interdites : pour la fonction f définie par f(x)=sqrt(x^2-1) (exemple de la page 14 de la doc), la compil donne comme affichage "Erreur Xcas"
Je n'ai pas ce problème. Peut-être que cmathluatex.lua du répertoire texlive/texmf-local est défectueux, comme c'était le cas de celui du répertoire texworks.
yax44 a écrit : 3) Pour les graphiques :
si je tente l'exemple de la page 26 de la doc, j'ai un message d'erreur pour l'option Stealth utilisée dans l'affichage des axes : Package pgf Error : unknown arrow tip kind 'Stealth'
Il faut mettre à jour le fichier cmathluatex.sty qui contient l'instruction \usetikzlibrary[arrows.meta] qui permet l'usage de Stealth
yax44 a écrit : Au sujet des graphiques, est-ce qu'il y a des fonctions automatisant le tracé des courbes ? je n'ai rien vu dans la doc à ce sujet.
Quel genre d'automatisation ? Donnez moi l'instruction que vous voudriez avoir...
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,

J'ai vérifié pour le fichier cmathluatex.lua : j'ai le même dans les répertoires texlive\texmf-config\texworks\scripts\Cmath et texlive\Mes documents.
Je ne l'avais pas dans texlive\texmf-local : je l'ai mis mais ça ne change rien.
J'ai donc toujours les mêmes problèmes :
* compil avec Ctrl+F9 : OK mais compil avec F9 seul : KO; toujours la même sortie 1/(x-3)+1/(2x+1)
* pour les doubles barres, c'est OK : à l'impression, elles sont bien là; par contre, je n'arrive pas à avoir le tableau de variations d'une fonction racine carrée : que ce soit celle de la page 14 de la doc ou toute autre fonction racine carrée, j'ai Erreur Xcas ??
* pour Stealth : le fichier cmathluatex.sty contient bien l'instruction \usetikzlibrary[arrows.meta]

Pour les graphiques, quand je parlais d'automatisation, je pensais à une fonction (comme TVar ou autre) qui permettrait d'avoir immédiatement le code du bas de la page 26 pour une courbe du type y=f(x), à une autre fonction qui permettrait d'avoir le code du bas de la page 28 pour une courbe paramétrée, etc.


Merci d'avance pour votre aide.

Jean-François
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

yax44 a écrit :Bonjour,
J'ai vérifié pour le fichier cmathluatex.lua : j'ai le même dans les répertoires texlive\texmf-config\texworks\scripts\Cmath et texlive\Mes documents. Je ne l'avais pas dans texlive\texmf-local : je l'ai mis mais ça ne change rien.
Pourquoi le mettre dans Mes Documents si vous utilisez le package cmathluatex ?
Je vous conseille d'identifier la version qui sert à la compilation (celle de texworks fonctionne bien, ne pas y toucher) : renommez tous les cmathluatex.lua jusqu'à obtenir une erreur de compilation et vérifiez que la version qui servait est bien correcte. Si cela marche avec Ctrl+F9 dans texworks, cela doit marcher avec la compilation lualatex puisque c'est le même code qui est exécuté.
yax44 a écrit :J'ai donc toujours les mêmes problèmes :
* compil avec Ctrl+F9 : OK mais compil avec F9 seul : KO; toujours la même sortie 1/(x-3)+1/(2x+1)
* pour les doubles barres, c'est OK : à l'impression, elles sont bien là; par contre, je n'arrive pas à avoir le tableau de variations d'une fonction racine carrée : que ce soit celle de la page 14 de la doc ou toute autre fonction racine carrée, j'ai Erreur Xcas ??
* pour Stealth : le fichier cmathluatex.sty contient bien l'instruction \usetikzlibrary[arrows.meta]
Envoyez moi un fichier tex qui regroupe tous ces problèmes car je ne m'explique pas tous ces dysfonctionnements.
yax44 a écrit :Pour les graphiques, quand je parlais d'automatisation, je pensais à une fonction (comme TVar ou autre) qui permettrait d'avoir immédiatement le code du bas de la page 26 pour une courbe du type y=f(x), à une autre fonction qui permettrait d'avoir le code du bas de la page 28 pour une courbe paramétrée, etc.
Oui c'est une bonne idée : des instructions simples qui feraient les tracés avec les options de base et qui pourraient se personnaliser facilement avec Ctrl+F9, comme les tableaux.
Je vais y réfléchir.
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,

Visiblement, la version qui sert à la compilation est celle qui est présente dans texlive\Mes documents.
En effet, si je renomme cette version ou que je la supprime, j'ai une erreur à la compilation.
J'ai remplacé ce fichier par celui présent dans texlive\texmf-config\texworks\scripts\Cmath mais cela ne règle pas le problème.

Lorsque j'essaye de mettre en pièce jointe le fichier .tex par le biais de ce forum, j'ai une erreur qui me dit que cette extension ne peut pas être prise en charge. Avez-vous une adresse email ?

Merci d'avance.

Jean-François
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

j'ai activé l'extension tex. Envoyez moi votre fichier.
Répondre