problème

Cmath pour LuaLaTeX
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,

Voici en pièce jointe le fichier .tex
Merci d'avance.

jean-françois
Pièces jointes
Document test pour CmathLuaTeX.tex
(11.4 Kio) Téléchargé 680 fois
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

Bonsoir,
après avoir mis mon fichier cmathluatex.lua dans le même répertoire que ce document test, j'ai compilé sans erreur. Je joins le résultat pdf.
Quel est le message d'erreur ? à quelle ligne ?
Pièces jointes
Document test pour CmathLuaTeX.pdf
(104.98 Kio) Téléchargé 669 fois
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,

En fait, la compilation aboutit mais le résultat n'est pas le même que le vôtre.
Je joins mon résultat pdf à ce message et vous verrez que :
- toutes les fonctions en F9 renvoient bizarrement 1/(x-3)+1/(2x+1)
- toutes les fonctions en Ctrl+F9 fonctionnent
- de plus, pour avoir les graphiques, je suis obligé de ne pas utiliser l'option Stealth sinon j'ai "Package Pgf Error : unknown arrow tip kind 'Stealth'" même avec la mise à jour du fichier cmathlualatex.sty (il contient bien l'instruction \usetikzlibrary[arrows.meta]).

PS : le fichier cmathlualatex.lua se trouve dans le même répertoire que le document test .tex

Merci d'avance.

jean-françois
Pièces jointes
Document test pour CmathLuaTeX.pdf
(104.41 Kio) Téléchargé 703 fois
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

Bonsoir,
pour les graphiques, je pense comprendre. Vous n'utilisez pas le fichier cmathluatex.sty puisque dans le document test que j'ai reçu, c'est l'utilisation sans package de cmathluatex que vous utilisez : tout le nécessaire est dans le préambule. C'est pour ça que le fichier cmathluatex.lua doit être dans le même répertoire que le document test. Vous devriez essayer de compiler avec la version package (cf documentation), par exemple :

Code : Tout sélectionner

\documentclass[a4paper,10pt]{article}
\usepackage{fontspec}
\usepackage{CmathLuaTeX}
\begin{document}
$\Cmath{sin{π/2}=1}$
\end{document}
Il ne devrait plus y avoir besoin de mettre cmathluatex.lua dans le répertoire du document (renommez la pour voir si ça compile toujours bien). Ensuite tentez un graphique avec Stealth.

On verra après ce test pour régler le souci du F9.
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,

Merci pour votre patience avec moi !

Voilà ce que j'ai fait :
- j'ai supprimé les fichiers CmathLuaTex.lua et CmathLuaTex.sty du répertoire "Mes documents" qui contient le fichier test
- j'ai mis les deux fichiers .sty et .lua dans le l'arborescence /texlive/texmf-local/tex/latex/CmathLuaTex de ma clé usb
En compilant avec la version package, je n'ai plus d'erreur de compilation mais les flèches n'apparaissent pas sur le graphique.

Merci d'avance.

jean-françois
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

Y a-t-il bien la ligne

Code : Tout sélectionner

\usetikzlibrary[arrows.meta]
dans le fichier sty ?
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Oui cette ligne y est bien :(
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

Pouvez-vous m'envoyer le document tex et le pdf produit ?
yax44
Messages : 26
Inscription : 01 oct. 2016, 09:52

Re: problème

Message par yax44 »

Bonjour,

Les voici en pièces jointes.
Merci.

jean-françois
Pièces jointes
Document test bis.tex
(9.49 Kio) Téléchargé 1385 fois
Document test bis.pdf
(104.44 Kio) Téléchargé 2523 fois
Avatar de l’utilisateur
cdeval
Administrateur du site
Messages : 34
Inscription : 03 sept. 2016, 13:36

Re: problème

Message par cdeval »

Bonsoir,
vous avez une erreur de syntaxe à ces deux lignes :

Code : Tout sélectionner

\Cmath{tikzAxeX([line width=0.6pt],-{Stealth[round]}],step=1)}
\Cmath{tikzAxeY([line width=0.6pt],-{Stealth[round]}],step=1,zero=false)}
Enlevez les crochets après les "0.6pt" et les flèches apparaîtront !
Répondre